UML Class Diagram don't generate java code

I have installed UML lab on fresh download eclipse Juno (I've tried Kepler as well). Created new UML Lab java project draw some classes with methods and parameters, but I don't see any generated java code.

Thanks for help and sorry for my English.


  • Hi Dominik,

    did you give our code generation tutorial a try? You can find it here:

    On saving the diagram for the first time, UML Lab asks you if it should generate code automatically. In addition, you can generate code at any time by using the Generate Code entry from the context menu or the UML Lab menu.

    After generating code, you should find the generated source code in the src/ or generated/ folder of your project (depending on how you created the diagram and model). You can also navigate from the model into the source code, by right-clicking any model element and choosing "Navigate to -> Source".

    Hope this helps :)

    Best regards
  • edited August 2013
    Ah - just one another thing. Did you install "UML Lab Class Diagrams" or "UML Lab Modeling IDE"? The former doesn't contain code generation ;).

    Please download UML Lab Modeling IDE directly from our website, or by using this entry from the Eclipse marketplace:
  • Hi, I've got installed UML Lab Modeling IDE. I tried do example, but in step with configure class diagram I see only UML_Lab_Shop_Example on left side and list on right side is empty. Btw. when I create diagram UML Lab it doesn't ask me about generating.
  • Hi Dominik,

    could you please check if com.yattasolutions.codegen and com.yattasolutions.codegen.reverse are installed? To do so, navigate in Eclipse to "Help -> About Eclipse/UML Lab -> Installation Details". In this dialog, open the tab "Features", sort by "Feature Id" and lookup our two features.

    If they are installed, please send me your error log (.log file in your Eclipse workspace .Metadata directory). You can send it by email to

    Best regards
  • Hi, there is installed only com.yattasolutions.ecore and com.yattasolutions.umllab, but from subcategory UML Lab is everything installed. btw. licence expired after one day.
  • Ok, very strange. I'd suggest uninstalling all com.yattasolutions.* features (in this dialog) and then re-installing it via Eclipse marketplace.

    Please check the error log when doing so.
  • edited August 2013
    Hi, I reinstall it. In log is only no valid license is available and in installation detail are com.yattasolutions.codegen.reverse and com.yattasolutions.codegen.
    btw. I can't try if it is working because of licence expired.
    btw2. log attached.
  • I'll send a trial license to your email adress. That way you can continue evaluating UML Lab :)
  • Hi, thanks for licence, with new licence it's working.
  • Great to hear!
Sign In or Register to comment.