Prerequisites for installing UML Lab

Hello,

I have a recent Windows 8 installation with Java SE 7u9 and latest JDK installed.

I have NOT installed Eclipse (I use IntelliJ for work).

I install UML Lab, then try to load the executable, and nothing happens.

Is Eclipse a prerequisite for this product?

I keep seeing "Eclipse" mentioned everywhere. I assumed your release (download) from the website would bundle what was necessary from Eclipse to run stand alone.

Is this correct or not?

Cheers,
R


Comments

  • It would appear that the default link (shortcut) configured in the Start Menu for the X64 edition of UML Lab running under Windows 8 points to:

    "C:\Program Files\UMLLAB\umllab.exe" starting in the containing folder.

    By changing the shortcut to point to "C:\Program Files\UMLLab\UMLLab\UMLLab.exe" and the starting directory to the containing folder of the executable, the product now launches correctly.

    Note, I did NOT change the default installation directory upon install.

    Perhaps you should update your installer for the next release to include a valid .lnk?
  • Hi,

    Thank you for reporting this issue. I can confirm this bug and I was able to reproduce it. We'll fix it and update the installer later this day.

    Regarding your question about Eclipse: Yes, the UML Lab downloads on our website (both the Windows exe and the zips for Linux and Mac) also contain a complete Eclipse. If you already had an Eclipse installation, you could also use the update-site to install UML Lab into it.

    Best,
    Manuel
  • Hi,

    Meanwhile we released an updated UML Lab installer. Thanks again for reporting the problem.

    Have a nice weekend,
    Manuel
Sign In or Register to comment.