NullPointerException with Eclipse 3.8

edited July 2012 in Other
Hello,

after installing, I get the following error when I try to create a class diagram.

I use UML Lab Modeling IDE 1.5.0.201206271716 with the new Eclipse 3.8

Regards,
Michael



!ENTRY com.yattasolutions.umllab 4 0 2012-07-27 10:28:23.694
!MESSAGE UML Lab internal error: Unexpected Exception (org.eclipse.core.commands.ExecutionException: While executing the operation, an exception occurred)
!STACK 0
org.eclipse.core.commands.ExecutionException: While executing the operation, an exception occurred
at org.eclipse.core.commands.operations.DefaultOperationHistory.execute(DefaultOperationHistory.java:521)
at com.yattasolutions.obf.ld.x.c(SourceFile:842)
at com.yattasolutions.obf.ld.x.a(SourceFile:809)
at com.yattasolutions.obf.ld.x.b(SourceFile:709)
at com.yattasolutions.obf.ld.x.a(SourceFile:628)
at com.yattasolutions.obf.ld.z.a(SourceFile:171)
at com.yattasolutions.obf.ld.z$b.run(SourceFile:78)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
Caused by: java.lang.NullPointerException
at com.yattasolutions.obf.aa.a.cq(SourceFile:236)
at com.yattasolutions.obf.aa.a.cC(SourceFile:611)
at com.yattasolutions.obf.cr.g.doExecute(SourceFile:81)
at com.yattasolutions.obf.ld.u.execute(SourceFile:212)
at com.yattasolutions.obf.ld.x.b(SourceFile:834)
at com.yattasolutions.obf.ld.x$2.run(SourceFile:788)
at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2344)
at com.yattasolutions.obf.ld.x.a(SourceFile:800)
at com.yattasolutions.obf.ld.x.b(SourceFile:709)
at com.yattasolutions.obf.ld.x.a(SourceFile:628)
at com.yattasolutions.obf.y.a.a(SourceFile:35)
at com.yattasolutions.obf.h.a.a(SourceFile:404)
at com.yattasolutions.obf.h.a.a(SourceFile:390)
at com.yattasolutions.obf.aa.g.doExecute(SourceFile:122)
at com.yattasolutions.obf.ld.u.execute(SourceFile:212)
at org.eclipse.core.commands.operations.DefaultOperationHistory.execute(DefaultOperationHistory.java:513)
... 7 more

Comments

  • Hello Michael,

    I created a ticket for your issue (http://trac.yatta.de/ticket/100284). We'll try reproducing the bug and get back to you as soon as possible.

    Regards,
    Manuel
  • Hi Michael,

    installing UML Lab into a freshly extracted Eclipse 3.8 and creating class diagrams afterwards worked fine for me.

    The stacktrace indicates that the plug-in "com.yattasolutions.codegen.reverse.oaw" is not available. Could you please check the installation details if the plug-in is available? See "Help->About->Installation Details->Plug-Ins".

    Additionally, could you please check your error log for problems starting plug-ins? If it's fine with you, you can also send me your .log file. It is located in the workspace's .metadata directory.

    As a workaround you can also download the UML Lab RCP, which is available here: http://uml-lab.com/download/.

    Best regards
    Manuel
Sign In or Register to comment.