Code Generation removed @Override annotations

Hello,

this is a problem I experience quite often. I reverse engineer changes to the code into the model and then the code generator removes the @Override annotations.
What can I do in order to make the code generator keep this annotation?

Moritz

Comments

  • Here are some screenshots of the differences
    Screen Shot 2012-06-21 at 12.07.54 PM.PNG
    2034 x 1194 - 295K
    Screen Shot 2012-06-21 at 12.07.49 PM.PNG
    2034 x 1194 - 324K
    Screen Shot 2012-06-21 at 12.07.42 PM.PNG
    2034 x 1194 - 266K
    Screen Shot 2012-06-21 at 12.07.38 PM.PNG
    2034 x 1194 - 279K
  • Hi Moritz,

    Thank you for reporting this issue. UML Lab should keep the @Override annotations in the code. Please help me to reproduce the problem.

    - What is the code style of the affected Operation in the UML model (Open the Properties View, select the Operation and open the tab "Code Style")
    - Which Stereotypes are applied on the Operation (Again in the Properties View, this time the contents of tab "Stereotypes")
    - What did you change in the code, to cause the Reverse Engineering?

    I'm looking forward to your answers.
    Manuel
  • Hello,

    I do not have a UML Model for this class! I added the package to reverse engineering to use some other classes. I changed nothing in this class. So I have no idea, where this comes from.

    Moritz
  • Hi Moritz,

    this is very strange. I'll keep on trying to reproduce the bug.

    Manuel
Sign In or Register to comment.