UML Lab and Javadoc

Hello,

I have big problems with Javadoc comments. UML Lab sometimes removes them or moves them to another position (sometimes at places which create compile error) , which is really annoying because commenting code requires a lot of time (currently I first create a backup of a file to secure my comments and copy and paste them back after closing the model). Where is the problem? I turned off "Show comment icons" in the UML Lab preferences.

Moritz

Comments

  • Mhm, UML Lab should not move comments in your source code to other positions.

    Could you please try to create a small example to reproduce the issue for me?
  • Ok, I will try, but not before this weekend (tomorrow is my last Abitur exam).
  • Good luck tomorrow :)
  • Sorry that I do not have uploaded an example until now, but there was just a lot of other stuff to do ...
    I do not have forget about that and will create an example later.
  • Here are some screenshots, where comments got lost.
    Still sorry, that I did not found time to create a reproducible test.
    Screen Shot 2012-04-18 at 8.07.13 AM.PNG
    1794 x 1164 - 256K
    Screen Shot 2012-04-18 at 8.16.24 AM.PNG
    1617 x 1082 - 104K
    Screen Shot 2012-04-18 at 8.16.33 AM.PNG
    1617 x 1082 - 114K
    Screen Shot 2012-04-18 at 8.16.38 AM.PNG
    1617 x 1082 - 109K
    Screen Shot 2012-04-18 at 8.16.44 AM.PNG
    1617 x 1082 - 115K
    Screen Shot 2012-04-18 at 8.16.41 AM.PNG
    1617 x 1082 - 118K
  • I tried to create a model which deletes the comments reproducibly, but I could not create such a model. Sorry.

    Moritz
  • Thanks for keeping up on this. Your screenshots gave me some ideas on what might have happened, so maybe we can provide a solution when we get on these points.

    Manuel
Sign In or Register to comment.