Conflicting Dependency

edited July 2011 in Eclipse
I'm receiving the following error on Windows 7 and Ubuntu 10.04 using Eclipse Indigo and Eclipse Helios:

Cannot complete the install because of a conflicting dependency.
Software being installed: UMLLab Modeling IDE 1.3.2.201106061744 (com.yattasolutions.umllab.feature.group 1.3.2.201106061744)
Only one of the following can be installed at once:
Core Runtime 3.6.0.v20100505 (org.eclipse.core.runtime 3.6.0.v20100505)
Core Runtime 3.7.0.v20110110 (org.eclipse.core.runtime 3.7.0.v20110110)
Cannot satisfy dependency:
From: UMLLab Reverse Engineering Feature 1.3.2.201106061744 (com.yattasolutions.codegen.reverse.feature.group 1.3.2.201106061744)
To: com.yattasolutions.codegen.reverse.oaw [1.3.2.201106061744]
Cannot satisfy dependency:
From: UML Lab Reverse Engineering oAW Plug-in 1.3.2.201106061744 (com.yattasolutions.codegen.reverse.oaw 1.3.2.201106061744)
To: bundle org.eclipse.core.runtime [3.5.0,3.7.0)
Cannot satisfy dependency:
From: All-in-one UML Lab Eclipse Patch Bundle 1.3.2.201106060307 (com.yattasolutions.patches.feature.group 1.3.2.201106060307)
To: org.eclipse.uml2.feature.group [3.1.2.v201010261927]
Cannot satisfy dependency:
From: UMLLab Modeling IDE 1.3.2.201106061744 (com.yattasolutions.umllab.feature.group 1.3.2.201106061744)
To: com.yattasolutions.codegen.reverse.feature.group [1.3.2.201106061744]
Cannot satisfy dependency:
From: UMLLab Modeling IDE 1.3.2.201106061744 (com.yattasolutions.umllab.feature.group 1.3.2.201106061744)
To: com.yattasolutions.patches.feature.group [1.3.2,1.4.0)
Cannot satisfy dependency:
From: EMF Ecore 2.7.0.v20110605-0747 (org.eclipse.emf.ecore 2.7.0.v20110605-0747)
To: bundle org.eclipse.core.runtime [3.7.0,4.0.0)
Cannot satisfy dependency:
From: EMF Change Edit 2.5.0.v20100521-1846 (org.eclipse.emf.ecore.change.edit 2.5.0.v20100521-1846)
To: bundle org.eclipse.emf.ecore [2.7.0,3.0.0)
Cannot satisfy dependency:
From: UML2 End-User Features 3.1.2.v201010261927 (org.eclipse.uml2.feature.group 3.1.2.v201010261927)
To: org.eclipse.emf.ecore.change.edit [2.5.0,3.0.0)

Has anyone else encountered this error? Apologies for this being in English; I figured Google Translate would suffice.

Comments

  • Hi,

    Thank you very much for your interest in our tool. UML Lab doesn't support Eclipse Indigo yet. We are working on the migration and expect it ready within the next weeks.

    I'll post the announcement here once it is ready.

    Best regards
    Manuel Bork
  • Glad to hear you're working on support for Indigo, but what about Helios not working? I get the error message posted in the first post when trying to install UML Lab via the Eclipse Marketplace in both Indigo and Helios.
  • Hi,

    the error message indicates you are installing into an Eclipse Indigo:

    > Core Runtime 3.7.0.v20110110 (org.eclipse.core.runtime 3.7.0.v20110110)

    What version is shown in Eclipse's About dialog? Be sure to download your Eclipse from the Helios download page:

    http://www.eclipse.org/downloads/packages/release/helios/sr2

    I just installed UML Lab into a freshly downloaded Helios SR2 successfully.

    Best regards
    Manuel Bork
  • I just uninstalled the Helios installation I had and started fresh. It worked. Thanks for the help.
  • Thats great, you're welcome.

    I'm also glad to announce the Indigo Release of UML Lab. If you want to give it a try just update your installation.

    Best regards
    Manuel Bork
Sign In or Register to comment.