Initializing Reverse Engineering has encountered a problem

Just installed yatta student edition and I am eager to start learning the software.

However, while I did not have any problems during installation, as soon as I try to reverse engineer a package, I get the following message:

An internal error occurred during: "Initializing Reverse Engineering".
org.eclipse.core.runtime.CoreException: Plug-in "com.yattasolutions.codegen.reverse.oaw" was unable to instantiate class "com.yattasolutions.obf.ae.f".

Found within the forums that it was already resolved, but I am having the problem.

I am running Windows 8.1 and
Eclipse Java EE IDE for Web Developers.

Version: Kepler Service Release 1
Build id: 20130919-0819

Any help will be appreciated

Comments

  • Hi Demxic,

    Strange, which version of UML Lab are you using? Please have a look into the about dialog. To which post in the forum are you referring?

    Manuel
  • Hi Manuel,

    I am currently running UML Lab
    Version: 1.6.1

    And I found the problem to be solved according to this post:

    http://trac.yatta.de/ticket/100314

    Danke Schön, Manuel. Any help will be mucha appreciated. ;)
  • Hi Manuel,

    I am still getting the same error message. I uninstalled and reinstalled UML Lab with no succes, whatsoever. According to post http://trac.yatta.de/ticket/100314 the problem has been solved, but it is not my case, I am still getting it.

    An internal error occurred during: "Initializing Reverse Engineering".
    org.eclipse.core.runtime.CoreException: Plug-in "com.yattasolutions.codegen.reverse.oaw" was unable to instantiate class "com.yattasolutions.obf.ae.f".

    I am currently running UML Lab
    Version: 1.6.1

    Please, any help will be much appreciated.
  • Demxic,

    the error message points to a problem during the initialization of the EMF modeling stack. This could be caused by a couple of things. Could you please post a full stack trace of the error up to the root error (just right-click on the Error Log entry and choose Copy)?

    Also, it would be helpful to get a full list of your installed plug-ins and features to identify the culprit. To do that, please open Help > About Eclipse > Installation Details > Configuration and find the line that says *** Features:. Copy everything from there up to *** User Preferences:, paste it into a file and attach it here. If the file is too large, you can also send it to support@yatta.de.
  • I was having the same issue, but I fixed it. It turned out UML Lab didn't like Java 8
    To fix this, I added the following to eclipse.ini. Adjust to reflect your Java version.

    -vm
    C:/Program Files/Java/jdk1.7.0_40/bin/javaw.exe
  • Hi Carsten.

    I downloaded eclipse again and installed uml lab from its market place. It is now running smoothly.

    Thank you all for your help.
  • Demxic, that's great to hear. Have fun modeling :)

    Jesse, thanks for the suggestion regarding Java 8.
Sign In or Register to comment.